Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey and James Northam -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fccuk.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
10 registered (metalste, jasgol, Dan, Joe78, arm, 1 invisible), 25 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
11537 Members
58 Forums
99632 Topics
1192740 Posts

Max Online: 546 @ 30/08/2007 17:16
Top Posters
stan 32076
barnacle 26263
bockers 20109
Theresa 19643
pinin_prestatyn 19636
JimO 17877
Vickster 15915
Nigel 15012
PeteP 14567
Marco20ValveT 12705
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1341278 - 08/05/2012 21:26 Fiat Stilo 1.2 Active - Issue
MarioCirillo Offline
Ex El Presidente
I AM a Coop

Registered: 17/07/2008
Posts: 11715
Loc: Watford
Hello Guys

Im wondering if anyone can help.
I have a 1.2 16v Active. I was driving yesterday and all of a sudden the car lost power and sounded very rough, it was missfireing like crazy. While this was happening the following was also happening:

I was getting ASR failure and engine failure flashing on the screen. I can also hear clicking of relays (constantly) coming from the fuse box and the petrol guage keeps moving up and down.

I had my dad check the car over we cleaned all of the earths and the issue was still there. Checked the battery and alternator and they were fine.

We ran a diagnostics and it showed "random missfire from 1 and 3". We changed the coils on 1 and 3 and the car started fine, no more clicking either, the fuel guage was still having a life of its own though!.

As soon as we drove the car out of the garage it all started again, missfire and clicking of relays along with engine and asr errors.

Any ideas would be grealy appriciated!!

Thanks

Mario

ps we also changed the relay in question...
_________________________
Proud Owner of Rosso Speed LE041

Top
#1341284 - 08/05/2012 21:36 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
johnnybravoturbo Offline
Club Member 185
Je suis un Coupé

Registered: 09/01/2006
Posts: 9466
Loc: Leicestershire
Which is the relay thats clicking.
Also as daft as it may sound have you replaced the plugs recently and if so has the issues been since then?

Check the Ecu isnt full of Water,and give the gearbox earth a good tug as iirc it affects the instrument cluster.You could try putting jump leads from the battery -IVE to the gearbox and the engine to see if it cures the fault.

Top
#1341288 - 08/05/2012 21:43 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
MarioCirillo Offline
Ex El Presidente
I AM a Coop

Registered: 17/07/2008
Posts: 11715
Loc: Watford
no idea i will have to have a look

nothings been done on the car for a long long time just happend out of the blue.... maybe thats the problem laugh coupe gets all the lovin stilo gets nothing... now they are both cloud9 laugh

will check the gearbox earth although i think we did.

The ecu is right next to the engine and is unlikely to get full of water but we did have a quick look and it seemed fine...
_________________________
Proud Owner of Rosso Speed LE041

Top
#1341289 - 08/05/2012 21:44 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
MarioCirillo Offline
Ex El Presidente
I AM a Coop

Registered: 17/07/2008
Posts: 11715
Loc: Watford
cleared errors using the software... they came back straight away grr
_________________________
Proud Owner of Rosso Speed LE041

Top
#1341297 - 08/05/2012 21:56 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
szkom Online   sleepy
Forum is my job

Registered: 13/09/2009
Posts: 3838
Loc: .
A quick check for bad main earths is checking how hot it gets. If it's shot you'll know about it.


Edited by szkom (08/05/2012 22:00)
Edit Reason: engine running obviously

Top
#1341321 - 08/05/2012 22:54 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
Alfa_Male Offline
Making a profit

Registered: 22/06/2009
Posts: 323
Loc: Essex
Mileage?

Top
#1341395 - 09/05/2012 09:34 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
MarioCirillo Offline
Ex El Presidente
I AM a Coop

Registered: 17/07/2008
Posts: 11715
Loc: Watford
around 100,000 ... why?
_________________________
Proud Owner of Rosso Speed LE041

Top
#1341472 - 09/05/2012 13:41 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
Marco20ValveT Offline
I AM a Coop

Registered: 03/09/2008
Posts: 12705
Loc: looking for another 20vt
scrap it laugh
_________________________
Torque Automotive LTD

Top
#1341476 - 09/05/2012 13:43 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
nismo Online   sleepy
Club Member 310
Je suis un Coupé

Registered: 21/12/2007
Posts: 9442
Loc: London
you can't scrap the BEAST .
_________________________

.. 359bhp & 434nm ..

Top
#1341481 - 09/05/2012 13:48 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
Nobby Offline
Je suis un Coupé

Registered: 16/12/2005
Posts: 8809
Loc: At a fancy jamboree
Watery fuse box?
_________________________
Daytona Grey RS6 Avant

Top
#1341511 - 09/05/2012 15:33 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
MarioCirillo Offline
Ex El Presidente
I AM a Coop

Registered: 17/07/2008
Posts: 11715
Loc: Watford
fuse box is in the car and is bone dry . All other electrics are cased in the engine bay frown

No marco im not scrapping it, its an aweseome car. has done me proud the past 6 years


Edited by nismo (09/05/2012 16:08)
Edit Reason: bad spelling
_________________________
Proud Owner of Rosso Speed LE041

Top
#1341630 - 09/05/2012 21:23 Re: Fiat Stilo 1.2 Active - Issue [Re: MarioCirillo]
Alfa_Male Offline
Making a profit

Registered: 22/06/2009
Posts: 323
Loc: Essex
Check and clean ECU earthing points (use electrical contact cleaner).
Has it been using any coolant?

Top